ump_ueberlastNach diversen Meldungen über den gescheiterten Start der Online-Reservierung für die Abwrackprämie scheint niemand vom BAFA oder der beauftragten IT-Firma fähig, den Aufrufen Herr zu werden.

Immerhin hat man es schon geschafft, bei Überlastung des Servers eine Fehlermeldung anzuzeigen. Nur ist die für den reibungslosen Betrieb des Onlineformulars bei Antragstellern, die gerade versuchen, das ausgefüllte Formular abzuschicken, alles andere als förderlich. Denn sie erzeugt unnötigen Traffic: Wenn ein Browser für diese zwei Sätze plus Überschrift mehr Daten vom Server abfragen muss (30 KiB) als z.B. beim Abruf der Google-Startseite (22 KiB), die wesentlich mehr tatsächliche Informationen enthält, dann ist das BAFA doch selbst schuld…

ump_umfang2

Umfang der Fehlermeldung des Online-Formulars für die Abwrackprämie

Mit dabei sind 1526 Zeilen (!!) Stylesheet in drei CSS-Dateien, von denen eigentlich keine einzige wirklich nötig ist um dem Besucher lediglich mitzuteilen, dass im Moment einfach nur nichts geht. Gleichzeitig geht dadurch aber noch weniger…

Das eigentliche Formular, was dann doch beim Neuladen gelegentlich erscheint (gabs da bei einigen Antragstellern gerade Mittagessen?), sieht übrigens so aus.

Formular Abwrackprämie

Für alle die "nur mal gucken" wollen

Change the World by Web

März 6, 2009

Plug-ins für WordPress schreiben und dabei Gutes tun – Chance, die man nutzen sollte.

Nachdem ich diesen Beitrag mit „SolidWorks mit OpenGL-behinderter Billigst-On-Board-Notebook-Grafikkarte“ betitelte, fiel mir ein, dass auch ein werter Besitzer dieses kostengünstigen Notebooks irgendwann einmal diese Zeilen liest… Tut mir leid, L.E.P!

Nahezu unzumutbare CAD-Software auf gerade noch so zumutbaren Notebooks zum Laufen zu bringen grenzt an Selbstverstümmelung!

Falls doch noch irgendwo jemand versuchen sollte, auf einem MSI VR602-Notebook mit SiS Mirage 3 (on-chip, pfui!) Grafik“chip“ die CAD-Software SolidWorks 2008 zum Laufen zu bringen, der bewaffne sich mit Geduld und Spucke.

Wenn SolidWorks auch nach der tausendsten Neuinstallation beim Starten immer mit einem DLL-Fehler abschmiert, dann liegt es bei dieser Systemkonfiguration (+ WinXP) höchstwahrscheinlich an den Grafiktreibern. Die neuesten dieser Art zur Konfiguration passend herunterzuladen mag ja evtl. helfen. In meinem Fall hört der Post aber noch nicht auf… Da kommt also noch was.

Tatsächlich geholfen also hat viel mehr folgendes.

  • Registry: allen Einträgen mit dem Namen „Use Software OGL“ (Suchen mit F3), die in SolidWorks-„Ordnern“ zu finden sind, den Wert 1 (eins) verpassen (entspricht der Einstellung in SolidWorks, OpenGL per Software zu emulieren; .REG-Dateien folgen bald). Wer denkt, dass das reicht, der sollte trotzdem
  • auf der MSI-Downloadseite den Vista-Treiber (sic!) herunterladen und die darin im Ordner „VistaX86“ enthaltene Datei sisglv.dll in das Windows-System32-Verzeichnis extrahieren,
  • Registry: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\OpenGLDrivers\sisgl] „dll“=“sisglv.dll“ – sprich, den Wert der Zeichenkette „dll“ von „sisgl770.dll“ auf den neuen DLL-Dateinamen umstellen. Das ist der Verweis, auf den sich SolidWorks beim Starten verlässt. Die
    Änderung tangiert evtl. andere OpenGL-nutzende Programme, die ohne dieser aber wahrscheinlich ebenfalls nicht funktionieren (?).
  • SolidWorks starten und Daumen drücken! (falls es wider Erwarten nicht startet, bitte hier kommentieren… und falls doch, würd ich mich trotzdem über einen Wiederbesuch freuen. Danke!)